Author Topic: Pump never stops....  (Read 4357 times)

dochereford

  • Newbie
  • *
  • Posts: 3
    • View Profile
Pump never stops....
« on: June 25, 2016, 03:25:22 PM »
 I purchased a CSV kit and installed it using a Square_D 60/80 Pressure Switch

When I first installed it last weekend, everything seemed to be working perfectly.  I had the system cycling between 60-80 and holding a pressure of 70lbs when in use.  (Tank 55lbs of air)
Today, the pump doesn't shut off and stays at about 60lbs with no usage.  I've never had any issues with the pump before now.  I never run out of supply or anything like that.

1. I loosened the differential nut (B) on the pressure switch all the way.  No effect.
2. I loosened the adjustment stem on the CSV.  I can effect the pressure from 15lbs to 50lbs only.  Nothing higher than 50lbs.
3. When I turn off the pump breaker, I loose all pressure in the system in about 5 seconds.  The house supply value is closed.  (note: It was my understanding that I had a check valve on the pump itself so I didn't install the supplied valve that came with the kit.  That one is intended to go between the CSV and the pump)

Questions:
1. Did i purchase the wrong pressure switch option?
   Here are my pump specs:
   12 GPM
   3/4 HP
   230V
   Max Amp: 8.0
   SF 1.5
   3450 RPM
   Date: 11/93


2. Its like I have a faucet on somewhere that is leeching off water and pressure before the CSV value, which is the first thing of the line from the pump. 
Nothing I could find.  I have the house supply valve off so if there is, it must be underground?

Its been running for a few days before I noticed and I'm afraid the pump will burn up or already has been degraded.  Any help you can provide is appreciated.

« Last Edit: June 25, 2016, 04:05:09 PM by dochereford »

dochereford

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Pump never stops....
« Reply #1 on: June 25, 2016, 03:28:12 PM »
Here are the pump specs from the sticker.

Cary Austin

  • Inventor, Owner, Chief Cook and Bottle Washer
  • Administrator
  • Newbie
  • *****
  • Posts: 1471
    • View Profile
    • http://www.cyclestopvalves.com
Re: Pump never stops....
« Reply #2 on: June 25, 2016, 03:48:25 PM »
I wish you had purchased a real Pside-Kick kit from us.  Things like this is why it pays to buy from someone that can help when needed.  Plus a real Pside-Kick kit would have fit in half a that space and not had all those extra parts that are not needed.

But I will help anyway, even over the weekend.  The CSV is working fine.  A 12 gpm, 3/4hp pump can build about 120 psi before the CSV.  Either a hose clamp came loose or a pipe has split somewhere before the CSV.

dochereford

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Pump never stops....
« Reply #3 on: June 25, 2016, 03:56:04 PM »
Duly noted.  I wish I had known honestly.  By the looks of it, I could have save about 60%. Damn.
Thank you for your input.

So ignoring the check valve scenario, I need to start digging.  I should probably hire a pro.
Do you think I should turn off the pump when not using until I get it looked at?
« Last Edit: June 25, 2016, 04:04:15 PM by dochereford »

Cary Austin

  • Inventor, Owner, Chief Cook and Bottle Washer
  • Administrator
  • Newbie
  • *****
  • Posts: 1471
    • View Profile
    • http://www.cyclestopvalves.com
Re: Pump never stops....
« Reply #4 on: June 25, 2016, 08:44:05 PM »
Start st the well. See if the pipe down the well is holding water.  If not, the split is down the well.  If the pipe down the well is full of water, then you will probably have to dig.  And yes turn off pump unless you are using water.