Author Topic: Question about my new CSV  (Read 11153 times)

Cary Austin

  • Inventor, Owner, Chief Cook and Bottle Washer
  • Administrator
  • Newbie
  • *****
  • Posts: 1433
    • View Profile
    • http://www.cyclestopvalves.com
Re: Question about my new CSV
« Reply #15 on: May 01, 2015, 07:03:00 AM »
Yeah it is probably a pump problem.  If it is a weak well, it will usually pump 10+ GPM for a few seconds at least.

New2CSV

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Question about my new CSV
« Reply #16 on: May 02, 2015, 12:51:36 PM »
Just in case, any recommendation on a replacement pump?

New2CSV

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Question about my new CSV
« Reply #17 on: May 19, 2015, 05:35:13 PM »

I ended up getting a Franklin Electric pump from a local well digger. I replaced the pump and the wire (it was worn through in at least one spot).

Sucker is pumping like crazy now.

I'm getting somewhere around 10-13 GPM from the drain valve/water hose in the basement.

I reset the pressure switch back to 40-60 PSI, adjusted the air pressure in the pressure tank, and adjusted the CSV to a steady 50 PSI (at 2-3 GPM flow).

Everything seems to be working as expected.

Thanks for your help!

Cary Austin

  • Inventor, Owner, Chief Cook and Bottle Washer
  • Administrator
  • Newbie
  • *****
  • Posts: 1433
    • View Profile
    • http://www.cyclestopvalves.com
Re: Question about my new CSV
« Reply #18 on: May 20, 2015, 07:04:27 AM »
Thanks for the update and sorry I missed the post about what brand of pump to use.  But the Franklin is as good as any.  Glad you got it working.